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Introduction 

    This is intended to be a refresher presentation to the 
GR program. It doesn’t cover every single feature in 
the program, but hits on those that I have found the 
most useful. This manual was made for GR2 Analyst; 
GR2 works similarly, but is missing a few features and 
some settings are in different locations. GR3 
operates quite differently and is not covered here. 

 

    Hopefully all of you can glean some new information 
and tricks on using the GR program from this 
presentation. With the right setup, GR can be a very 
powerful program. 
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Layout of the Program 
Overview 

Menu Bar Toolbar 

Color Table Product 
Information 

Radar Display Window Status Bar 



Layout of the Program 
Component Descriptions 

• Main Menu 

– Access to almost all of the settings for GR 

• Toolbar 

– Shortcuts to the most common options (loading data, 
animation, viewing options, and storm motion). Mousing 
over each shortcut gives its description. 

• Color Table 

– Color table for the currently selected product 

• Radar Display Window 

– Displays the currently loaded data 



Layout of the Program 
Component Descriptions 

Status Bar 

Shapefile Data at 
Cursor (ex. Road 
Name) 

Cursor Azimuth 
and Range from 
Radar 

Cursor Readout 
of Pixel Value 

Lat and Lon of 
Cursor  

Height of Radar 
Beam at Cursor 

Live Data Polling 
Status 

Product Information 

Site ID, time of the volume scan and elevation sweep, VCP, and 
the user-set storm motion 

Available products to choose from 

Available tilts to choose from 

Back to Table of Contents 



Site Selection 
Changing Sites and Startup Site 

• In Menu Bar go to Site -> Select… 

– Choose your site from the list that opens 

– You can also change to a nearby site by clicking on the 
radar ID in the Radar Display Window 

• To change the startup site 

– Go to Site -> Settings… 

– In the Startup Site box, click  
Change and select the site 
from the provided list 

– Click OK once done 

 

 



• User-defined favorite radars will be displayed in the 
Site menu 
– Note: Sites will always be displayed in  

           alphabetical order by site ID 

• To configure Favorites: 
– Go to Site -> Settings 

– In the Favorite Sites box, click Add 

– Select the site from the list and click OK 
• You will have to do this for each site 

– To remove a site from your favorites, select 
the site from your list and click Remove 

– Click OK in the Site Settings box when done 

 

Site Selection 
Favorite Sites 

Back to Table of Contents 



Loading Radar Imagery 
Loading Archived Data 

• In Menu Bar go to File -> Open 

               OR 

• Click the       icon on the Toolbar  
– Navigate to the folder containing the data, use the shift key to 

highlight the desired time range, then click open 

• You can also drag and drop the radar files you wish to load  
directly from the Windows Explorer into GR. 

• Note: If you are polling live data, you must turn off polling to 
load archived data. 



Loading Radar Imagery 
Loading Live Data 

• To start downloading live data 
– Go to File -> Start Polling (       on the Toolbar) 

– Note: A polling site must have been set up beforehand—this should be 
either the CRH site or the IEM feed 

• To load previous volume scans 
– Go to File -> Start Archiver (       on the Toolbar) 

– To configure how many volume scans GR downloads and how often it 
polls for data, see the Editing Settings section 

• To stop live polling without shutting GR down 
– Go to File -> Stop Polling (       on the Toolbar) 

Back to Table of Contents 



Loading Additional Overlays 
Shapefiles 

• Shapefiles are static GIS files that are meant to be 
additions to the overlays already provided in GR 

– Shapefiles require both a “shape file” and a “style file” 

– To load a shapefile, go to GIS -> Load ShapeFile 

– The Shape File Loader box will open 

 
 

 

 

 

 

 

   Continued on the Next Page 

 



Loading Additional Overlays 
Shapefiles 

• In the left hand box, click the      button and navigate 
to the directory containing the shape file. Select the 
shape file and click Open 

• Perform the same steps for the right hand box, but 
this time navigating to the location of the style file 
(many times they are in the same directory). 

• Once both of these are loaded, click the Import 
button 

 

Example on the Next Page 

 



Loading Additional Overlays 
Shapefiles Example: Loading CWA Roads 

• From the Shape File Loader window, click the      button on the 
left side. 



Loading Additional Overlays 
Shapefiles Example: Loading CWA Roads 

• Navigate to G:\GibsonRidge\Shapefiles\Roads 

• Select the “dmx-cwa-roads.shp” file. Click Open 



Loading Additional Overlays 
Shapefiles Example: Loading CWA Roads 

• Next, click the       button on the right side. 



Loading Additional Overlays 
Shapefiles Example: Loading CWA Roads 

• GR will open the same directory that the shape file was in 

• In this case, there is only one style file to choose from 

• Select this file (“tigerroads-new.sty”) and click Open 



Loading Additional Overlays 
Shapefiles Example: Loading CWA Roads 

• Finally, click Import 

• Once the shapefile has loaded in the Radar Display Window, click Close 

 

 

 

 

 

 

 

 

• To avoid the “double highways”, click off Show Base Roads under the GIS menu. 
See the GIS Menu page for more information. 



Loading Additional Overlays 
Placefiles 

• Placefiles are custom text files that are specifically 
designed for GR 

– Can be either static files (spotter residences, law 
enforcement locations, etc.) or dynamically updated on a 
server (surface obs, SPC outlooks and watches, webcam 
images, etc.) 

• To load either type of placefile, make sure the 
Windows -> Show Placefile Manager option is 
checked. When it is checked, a small window should 
open up on the screen. 

      Continued on Next Page 



Loading Additional Overlays 
Placefiles: Loading 

• Click the       button on the Placefile Manager window 
– The following window will open 

 

 

 

 

– To load a static (saved) placefile, click the      button and 
navigate to the file on the computer. 

– To load a placefile located on the Internet, simply paste the 
address to the placefile in the text field (to the left of the     
     button) 

– Click OK when done.  
Repeat the process above for each placefile 



Loading Additional Overlays 
Placefiles: Managing 

• Each placefile will be listed in the Placefile Manager window 
– To reorder the placefiles, click the placefile in the 

window and click either the      or      buttons 

– To remove a placefile, select the placefile and click  
the       button 

– The left checkbox next to each placefile toggles 
whether the placefile is visible on the map 

– The right checkbox toggles whether the placefile is 
visible above (unchecked) or below (checked) the  
radar image. 



Loading Additional Overlays 
Placefile Locations 

• Online Placefiles 
– http://www.meteor.iastate.edu/~ckarsten/chase/GR_Placefiles.php 

• ASOS/AWOS/RWIS/Meosnet Obs, SPC Outlooks and Watches, LSRs, Storm Report Generator (VERY COOL) 

– http://www.tornadocentral.com/grlevelx-placefiles.html  
• SPC Outlooks/Mesoscale Discussions/Watches and Surface Observations 

– http://mesonet.agron.iastate.edu/request/grx/ 
• Iowa surface obs (all networks), webcam images, NEXRAD Level 3 attributes 

– http://www.spotternetwork.org/gr-feeds.php 
• Spotter Network locations and reports 
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Loading Additional Overlays 
Backgrounds 

• Backgrounds consist of a bitmap image (.bmp) and a text file 
with latitude and longitude coordinates 
– The coordinates give the upper and lower bounds of the image 

(latitude) and the left and right bounds of the image (longitude) 

• To load a background image: 
– Go to GIS -> Settings -> Background...  

– Navigate to the location of the image on the computer (yellow arrow) 

– Type/paste the bounds of the image into the boxes at the bottom of 
the window (blue arrow) from the text 
file 



Loading Additional Overlays 
GIS Data 

• All of the overlays in GR can be turned on or off 

– Click any item in the GIS menu to turn it on or off 



Loading Additional Overlays 
Hail and MDA Icons 

• GR uses its own algorithms to calculate expected hail 
size and any mesos/TVSs, which are plotted on the 
radar display. 

• These can be turned on or off using the respective 
buttons on the toolbar (below) or the View -> Show 
Hail Icons and View -> Show MDA Icons menu 
options. 

MDA Icons Hail Icons 



Navigating through Radar Data 
Animating Images 

• The Toolbar contains the animation controls for the looping 
the data 

 

 

 

 

 

 
• To control looping speeds, see the Editing Settings section 

• Shortcut: You can also step through the images by clicking the Radar 
Display Window and using the left and right arrows on the keyboard  

First Image in 
Sequence 

Last Image in 
Sequence 

Play/Pause Loop 

Previous Image Next Image 

Back to Table of Contents 



Navigating through Radar Data 
Different Elevation Angles 

• There are two ways to change which elevation you 
are viewing: 
1. Simply click the desired tilt on the Product Information panel 

2. Shortcut: To scroll through the different tilts for a given product, click 
the current tilt with your mouse. There will now be a dotted box 
around the number (see image below). Now you can use your arrow 
keys to scroll through the tilts. 

- Down and Right: Move up in the volume scan 

- Up and Left: Move down in the volume scan 



Navigating through Radar Data 
Different Products 

• There are three ways to go about changing products 
– Simply click the radio button next to the product on the Product Information 

panel 

– Shortcut: To quickly scroll through multiple products at a given elevation 
angle, click the currently displayed product in the Product Information panel—
you’ll note that there is now a dotted box around the initials for the product 
(see image below) 

• You can now use the arrow keys to quickly scroll through the products. 
The Right and Down arrows move down the list, while Left and Up keys 
move up the list 

– You can also use the keyboard shortcut  
keys for each product. The key that 
corresponds to each product is  
underlined in the list 

– Example: Reflectivity = R, Velocity = V 
Storm Relative Velocity = S 



Navigating through Radar Data 
Notes on GR Products 

• GR calculates a number of Level III products using Level II data 

 

 

 

 

 

 

• Dual Pol Notes 
– Correlation coefficient is called RHO in GR, not CC 

– An extra dual-pol product is available in GR that is not viewable in AWIPS. This is phase 
shift, or PHI. This is the differential phase shift product before a distance derivative is 
applied to the data 

– Hydrometeor Classification Algorithm is listed as a product in GR2A, but is currently not 
available. Maybe this will be calculated in the future?? 

Level II Products Ingested by GR Level III Products Produced by GR 

• Base Reflectivity (BR) 
• Base Velocity (BV) 
• Spectrum Width (SW) 
• Differential Reflectivity (ZDR) 
• Correlation Coefficient (RHO) 
• Phase Shift (PHI) 

• Storm Relative Velocity (SRM) 
• Differential Phase Shift (KDP) 
• Echo Tops (ET) 
• Vertically Integrated Liquid (VIL/DVIL) 
• Probability of Severe Hail (POSH) 
• Maximum Estimated Hail Size (MEHS) 
• Normalized Rotation (NROT) 
• Hydrometeor Classification Algorithm (HCA) 

Back to Table of Contents 



Viewing Radar Data 
Zooming and Panning 

• To Zoom 
– Click in the Radar Display Window and use the scroll wheel on the 

mouse to zoom to a particular point 

– Click the      button on the Toolbar, then create a zoom rectangle on 
the Radar Display Window 

– Use the zoom controls on the Toolbar  

 

 

 

 

• To Pan 
– Click the      button on the Toolbar, the click and drag on the Radar 

Display Window to move the image around 

Zoom In 

Zoom Out 

Zoom Completely Out 



Viewing Radar Data 
Windows 

• You can view radar data in one, two, or four separate panels in 
the Radar Display Window, much like the four panel display in 
AWIPS 
– Windows -> One Panel to view one window 

– Windows -> Two Panels to view two panels side by side 

– Windows -> Four Panels to view four panels in the window 

• To add a product to each panel, click the panel (it becomes 
highlighted with a thin black box) and choose the desired 
product and elevation from the Product Information panel 

 



Viewing Radar Data 
Cross Sections (GR2A Only) 

• Cross sections can currently be made of the BR, BV, SRM, and 
SW products. 

• Click the      button on the Toolbar to activate the cross section 
tool. 

• Click and drag your mouse across the area you wish to make a 
cross section of. Release the mouse button when finished. 

• A separate cross-section window will open up. 



Viewing Radar Data 
Cross Section Window Panel 

Product to load as a cross section 

The cross section’s width and height 

3D: Cross section is displayed with the underlying base 
reflectivity image. Can be rotated freely with the mouse. 
2D: Cross section only 

Position: Moves the cross section back and forth in the 
horizontal. Is moved on a line tangential to its orientation. 
Swing: Pivots the cross section on its left axis by about 30° in 
either direction 

Turns smoothing on and off. Note: will only work if 
smoothing is activated on the main program window 

Syncs the cross section with the currently displayed 
time in the main window 



Viewing Options 
 Cross Section Window Notes 

• If environmental data is available, GR will plot the 0°C and  
-20° levels on the cross section as yellow and red lines, 
respectively 

• The status bar at the bottom of the cross section window is 
almost identical to the one in the main program 

• Unfortunately, there is no easy way to capture screenshots of 
cross sections. The easiest ways are by using the Microsoft 
Snipping Tool or hitting the Print Screen key (and pasting the 
image into an image program). 



Viewing Options 
Volumetric Display (GR2A Only) 

• Volumetric displays allow you to get a 3D look at a storm. 

• Like cross sections, volumetric displays are only available for 
BR, BV, SRM, and SW. 

• To create a volumetric display, click the       icon on the 
Toolbar. 

• Move your mouse to where you want the center of the cross 
section to be, then click and drag outward. A box will grow 
outward with your cursor showing the area that will be 
analyzed. 

• When you let go of your mouse button, the volumetric display 
will open in a new window.  



Viewing Options 
Volumetric Display (GR2A Only) 

• The volumetric display window consists of four parts 

Toolbar 

Product 
Information 
Panel 

Radar Display 
Status Bar 



Viewing Options 
Volumetric Display: Radar Display 

• The Radar Display shows a smoothed three dimensional radar image on 
top of the 0.5° image of that product 

• Click and drag your mouse on the display to rotate the image 

• Like a cross section, the 0°C and -20°C lines are plotted if the data is 
available as yellow and red lines, respectively 

 



Viewing Options 
Volumetric Display: Product Information Panel and Status Bar 

• Product Information Panel 

 

 

 

 

 

 

 

 

• The Status Bar is located at the bottom of the window and 
displays you cursor’s lat. and lon. and azimuth/range from 
radar 

Date and time of the volume scan start 

Available products to select from 

Lit Volume: View the storm using multiple 
transparent layers, which can be set by the user 
(see the color table section for more) 
Isosurface: Only display data that is of a certain 
value (again, see the color table section for more) 



Viewing Options 
Volumetric Display: Toolbar 

• Toolbar 
 

Save Image 

Animation Controls 

Sync with Main Window 

Volume Display Settings 
You shouldn’t have to change 
anything in here other than sky 
color 

Volume Alpha Settings 
Controls how the 3-D image 
looks, more on that on the 
following pages 

Light Settings 
Change the ambient light and 
light angle. Play with this until 
your heart is content 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Click on the         icon on the Toolbar. The Volume Alpha window will open 

• The color scale is oriented along the bottom of the window, with a line 
stretching from the left to right side of the window. This line controls the 
transparency of the colors 

• The closer to the top of the window the line is, the more opaque the color 
directly under the line is; the closer the line is to the bottom of the 
window, the more transparent the color under it becomes. 

• You use a series of click and drags with your mouse in the window to edit 
the transparency of colors 

 

 
Completely Opaque 

Completely Transparent 
Examples on 
Next Pages 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Let’s look at a few examples and the resulting volume images 
 

– When you first open the Volume Alpha window,  
it will likely look something like this  
(unless you’ve already edited it): 

 

And the volume image looks like this: 

But we can 
make this so 
much better… 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Let’s get rid of the low reflectivity values 
 

– Click and drag the cursor along the bottom of 
the window over the lower end of the scale to  
make the low values transparent 

 

And the volume image now looks like this: 

Somewhat better, 
but the green is still 
overpowering… 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Let’s lower the strength of the green and make it more transparent 
 

– Move the cursor a few shades of green up the  
scale, then drag a little ways off the bottom until  
you reach the yellows to make the rest of the greens 
transparent 

 

And the volume image now looks like this: 

Getting there, let’s 
do the same to the 
yellows… 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Now let’s make the yellows more transparent 
 

– Move the cursor a few shades of yellow up the  
scale, then drag a little ways off the bottom until  
you reach the oranges to make the rest of the yellows 
nearly transparent 

 

And the volume image now looks like this: 

That green is still a 
bit much… 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Now let’s make the greens more transparent 
 

– Drag the cursor along the spike over the green to 
dampen it out a bit. Also drag the cursor over the  
rest of the greens to make them more transparent 

 

And the volume image now looks like this: 

You’re probably 
getting the drift of 
what we’re doing. 
Let’s look at some 
final products… 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Hail Detection 
 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• See All Levels 
 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Base Velocity 
– Note that the transparency effects are 

applied to both inbound and outbound 
values 

 

From the July 11 
Derecho 



Viewing Options 
Volumetric Display: Editing the Lit Volume Colors 

• Saving your Settings 

– Once you’ve edited the transparency to your liking, you 
can save your settings by right clicking the Volume Alpha 
window and clicking “Save Alpha Table…” 

– You can then load your saved settings by right clicking the 
table and selecting them from the list on the pop up menu 

– The settings only work for the product they were created 
for (i.e. You can’t load the saved settings for a reflectivity 
product on a velocity image) 

 

     Tip: When editing the transparency curve on the Volume Alpha 
window, the exact value your cursor is at is displayed at the very top of 
the window 



Viewing Options 
Volumetric Display: Editing the Isosurface 

• To change the isosurface values, simply click and drag the triangle located 
under the color table on the Volume Alpha window 

 

 

• Examples 

 



Viewing Options 
Markers 

• Markers are useful for setting the SRM and measuring 
distances between points. 

• To set a marker, right click on the Radar Display Window at 
the spot you want to place the marker. A menu will open up 
(see image below). 

• Click “Place Marker Here”. 

• To remove the marker, right click the  
marker and select “Remove Marker” 



Viewing Options 
Home Markers 

• GR will erase any marker you set after exiting the program 

• To set a marker that GR will remember the next time you 
open the program: 
– Right click where you want to set the marker and click  

“Place Home Here” 

– To remove the Home marker, right click the marker and select 
“Remove Home” 

• By default, GR measures distances in the Toolbar  
from the radar, but you can also have GR measure  
distances from the marker or home point. 

– Right click anywhere in the Radar Display 
Window and choose from one of the three 
options near the bottom (red box) 



Viewing Options 
Setting Storm Motion for SRM Velocity 

• To set the storm motion manually 

– Click the      icon in the Toolbar. 

– A window will pop up allowing you to enter the storm’s 
motion and speed (Note: Storm motion should be the 
direction the storm is COMING from) 

• To have GR calculate the storm motion 
– Right click in the middle of storm (or edge, as long as you are 

consistent in step 3) and set a marker there 

– Advance several frames forward and backward 

– Right click on that region of the storm again and in the menu that 
opens up, select “Storm Motion from Marker” 



Viewing Options 
Smoothing and Dealiasing 

• To turn smoothing on and off for certain products, click the      
on the Toolbar or go to View -> Smoothing 

• To turn dealiasing on or off for velocity products, click the       
on the Toolbar or go to View -> Dealias Velocity  



Viewing Options 
Saving Images 

• Go to File -> Save Image—there will be four options 
– Entire Window: Captures the whole screen 

– Colors, Radar, Info: Captures the color table, radar display window, 
and product information panel 

– Colors and Radar: Captures the color table and radar display window 

– Radar Only: Captures the radar display window 

 

Back to Table of Contents 



Editing Settings 
Color Tables 

• To change the color table of a particular product: 
– First, display the product you wish to change (Z, V, SRM, etc) on the 

Radar Display Window 

– Then navigate to View -> Set Color Table… 

– Navigate to the directory that contains the color table and select it 

– Repeat this process for each product 

– Many color tables are stored under the G:\GibsonRidge\Color Tables 
directory 

– Play around and try them out! 



Editing Settings 
Configure Polling 

• Navigate to File -> Configure Polling 
– You cannot be downloading live data while changing these options 

• The window that opens up will display the sources of Level II 
data. The buttons on the right allow you to add/remove new 
sources and change their priority (top source is used first) 

• There are three configurable options on the bottom: 
– Polling Interval: How often GR 

checks for new radar data 

– Retain Files for: How long GR will 
keep the files it downloads before 
discarding them 

– Keep in Memory: How many scans 
GR will keep in memory that will 
be available for animating 

 



Editing Settings 
Warning Colors 

• To change how warnings look on the screen: 

– Go to View -> Warning Settings… 

– The window below will open 

– The warning server shouldn’t need to be touched 

– To change the color of the warning, click the colorized box 
next to the warning. 

– To change the width of the 
warning polygon, change 
the number in the pixels 
field 

– Click Apply to see the  
changes on the screen. 
 



Editing Settings 
Animation Settings 

• Very useful for controlling zoom settings and looping speeds 

• Go to View -> Animation Settings… 
– Zoom Steps: How smooth the zooming. Higher numbers = smoother 

– Zoom Amount: How much the program zooms in or out with each click/turn 
of the mouse wheel. I have found that a value of 1.20 is good to use. 

– Speed: How fast the images loop 

– Hold Last: How long GR holds the last image in a loop 

 



Editing Settings 
GIS Icons 

• All of the overlays in GR can be edited 

– The settings for each variable are under the GIS -> Settings 
menu 

– These settings include font color, 
font style, and line color. 

– City Labels defines the types 
of cities shown at a particular 
zoom level 

– Always Show List defines what 
cities are always shown regardless 
of the zoom level 



Editing Settings 
Algorithm Settings 

• The way in which GR calculates VIL and echo tops can 
be changed 

– Algorithms -> Algorithm Settings… 

– Max VIL DBZ: Maximum DBZ to be used in calculating VIL 

– Echo Tops DBZ: Lowest DBZ to be used in calculating echo 
tops 



Editing Settings 
Environmental Settings 

• GR downloads 0° and -20° C heights from the RUC 
when polling radar data in order to calculate hail 
sizes 
– These heights can be found at Algorithms -> Environment Settings… 

– Dates that data were downloaded on in the past are viewable on the 
left column 

– Once the date is selected, the data 
for each hour is viewable on the  
right window 

Back to Table of Contents 



The End!!! 


